Boards (Watterott)

Boardunterstüzungspaket für Arduino IDE v1.8+.

Installation

Folgende URL dem Arduino Boardverwalter (Datei->Voreinstellungen) hinzufügen:

https://github.com/watterott/Arduino-Boards/raw/master/package_watterott_index.json

Preferences

Dann den Arduino Boardverwalter öffnen (Werkzeuge->Board->Boardverwalter) und folgendes installieren: Watterott AVR Boards, Watterott SAMD Boards und Arduino SAMD Boards.

Wenn Sie den ATTinyCore von Spence Konde für die Nanite Boards verwenden möchten, dann diesen ebenfalls mit dem Arduino Boardverwalter installieren. Die URL lautet: http://drazzy.com/package_drazzy.com_index.json

Boards Manager

Bekannte Probleme

Windows

Manchmal wird der Treiber für den USB-Bootloader (Caterina oder Micronucleus) nicht richtig geladen. Dies ist der Fall, wenn Hochladen abgeschlossen. nach dem Programmiervorgang nicht angezeigt wird. Überprüfen Sie den Treiberstatus im Geräte-Manager, wenn der Bootloader aktiv ist (Caterina nach dem das Hochladen gestartet wurde und Micronucleus nach einem Reset). Wenn Sie den Treiber nicht unter Windows 8 oder höher installieren können, dann deaktivieren Sie die Überprüfung der Treibersignatur.

Linux

The Modem Manager can cause problems, because it detects Serial Ports (e.g. of the USB Bootloader) as a modem. So we recommend to uninstall/remove the Modem Manager:

  • $ sudo apt-get uninstall modemmanager

As alternative it is also possible to add a backlist rule for the USB device to the file 77-mm-usb-device-blacklist.rules.

Micronucleus Bootloader

Der Micronucleus-Bootloader wird nicht automatisch gestartet. Sie müssen den Resettaster drücken, um den Bootloader zu aktivieren nachdem Hochladen… in der Arduino IDE angezeigt wird.

Wenn der Fehler Bitte wählen Sie einen Port vor dem Hochladen angezeigt wird und kein Port ausgewählt werden kann, dann bearbeiten Sie die Datei preferences.txt im Benutzerverzeichnis und fügen Sie einen standardmäßigen seriellen Port mit serial.port=COM1 hinzu. Die Datei kann durch Klicken auf den Link im unteren Bereich des Voreinstellungsfensters (Datei->Voreinstellungen) gesucht werden. Die Datei kann nur geändert werden, wenn die IDE nicht ausgeführt wird.

Versuchen Sie bei Upload-/Verbindungsproblemen ein kurzes USB-Kabel (<30cm) zu verwenden.

Das Micronucleus-Uploadprogram benötigt Root-Rechte, daher muss die Arduino IDE mit sudo gestartet werden. Oder es kann auch eine Regel erstellt werden, die Benutzern ohne Rootberechtigung Zugriff auf das Micronucleus USB-Gerät gewährt. Dazu einen der Befehle ausführen - abhängig von ihrem System:

  • $ sudo nano /etc/udev/rules.d/49-micronucleus.rules oder
  • $ sudo nano /lib/udev/rules.d/49-micronucleus.rules

und folgende Zeilen der Datei hinzufügen:

SUBSYSTEMS=="usb", ATTRS{idVendor}=="16d0", ATTRS{idProduct}=="0753", MODE:="0666", ENV{MTP_NO_PROBE}="1"
KERNEL=="ttyACM*", ATTRS{idVendor}=="16d0", ATTRS{idProduct}=="0753", MODE:="0666", ENV{ID_MM_DEVICE_IGNORE}="1"

Neuladen der udev rules: $ sudo udevadm control --reload-rules

VCP+MSC Bootloader

Der Bootloader kann über die Arduino IDE oder durch zwei Resetvorgänge innerhalb von 0,5s aktiviert werden (doppelter Reset).

Wenn der Bootloader aktiv ist, kann ein neues Programm über die Arduino IDE und die serielle Schnittstelle oder über das Massenspeichergerät aufgespielt werden. Bei Verwendung des Massenspeichergerätes einfach eine neue Binärdatei (.bin) auf das Laufwerk kopieren.

Unter Linux Mac kann der dd Befehl zum Schreiben des Programms verwendet werden: $ dd if=APP.BIN of=/media/DRIVENAME/APP.BIN conv=notrunc

Eine Binärdatei kann in der Arduino IDE mit dem Befehl Sketch->Kompilierte Binärdatei exportiert erzeugt und exportiert werden.

Fehlerbehebung

Siehe Seite zur Fehlerbehebung.